Results 1 to 5 of 5
  1. #1
    unpecador's Avatar
    unpecador is offline Senior Member HGF Gold Member
    Join Date
    May 2008
    Location
    California
    Posts
    1,862

    Just got back from the range

    Everything was going fine after shooting about 100 rounds with my P01 then I had a problem, a round failed to feed properly, the slide was stuck halfway. I cleared it and after that all went well for the rest of the session. I have fired thousands of rounds with this gun and this is my first experience with this problem. I know that is a very good ratio but it still left me with a bad feeling for obvious reasons. It was also the first time that I was shooting Winchester ammo from Wal-Mart, was it the ammo? The mag? I don't know, anybody have advice?

  2. #2
    GTD
    GTD is offline In Time Out
    Join Date
    Dec 2007
    Posts
    73
    I would try not to worry about it, unless it happens again.

  3. #3
    tony pasley's Avatar
    tony pasley is online now Senior Member
    Join Date
    May 2006
    Location
    clyde n.c.
    Posts
    2,171
    Most likely a weak round out of the box.

  4. #4
    Baldy's Avatar
    Baldy is offline Senior Member
    Join Date
    Jun 2006
    Location
    Port St.John,FL.
    Posts
    6,740
    I have shot Winchester for many years and yes once in awhile you get a bad one. No big deal. Your all right.

  5. #5
    unpecador's Avatar
    unpecador is offline Senior Member HGF Gold Member
    Join Date
    May 2008
    Location
    California
    Posts
    1,862
    Thanks guys, sounds like the ammo, that's ok, it's practice ammo anyways

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

» Springfield Armory

» HGF Sponsors

Powered by vBadvanced CMPS v4.2.1