Results 1 to 9 of 9
  1. #1
    rbwomble is offline Junior Member
    Join Date
    Dec 2008
    Location
    Wichita Falls, Tx
    Posts
    18

    Kimber feed problem

    When I load practically any cheaper "target practice" bullets (solid nose) in either my Eclipse Target or the TLE/RL it jams. Not when it's shooting (never), but when I load the magazine with the slide back and push the slide closure button.....it never feeds the whole way....I have to almost force forward the slide to get the bullet in the chamber. It jams also sometimes if I pull the slide back when it is already in the open position....trying to help it feed right. It shoots great after that! Never a jam! I don't have that problem when I put in my defensive bullets (Hornady TAPS .45) Anyone have a clue?

  2. Ads
  3. #2
    BeefyBeefo's Avatar
    BeefyBeefo is offline Senior Member
    Join Date
    Jan 2008
    Location
    CO
    Posts
    2,873
    Not sure I totally understand. You've tried the "slingshot" method, and it still wouldn't chamber? Meaning, put the loaded magazine in the gun, pull the slide all the way back and let go (do not ride it forward).

    -Jeff-

  4. #3
    rbwomble is offline Junior Member
    Join Date
    Dec 2008
    Location
    Wichita Falls, Tx
    Posts
    18
    Quote Originally Posted by BeefyBeefo View Post
    Not sure I totally understand. You've tried the "slingshot" method, and it still wouldn't chamber? Meaning, put the loaded magazine in the gun, pull the slide all the way back and let go (do not ride it forward).

    -Jeff-
    Yes, the sling shot method seems to only work when I also pushed it back. In other words... I pulled it back, but gave it a nudge going forward. It would fail to feed 80% of the time if I just do the slingshot method. It never works just pushing in the slide release button with it open after inserting the magazine either.

  5. #4
    cruzthepug's Avatar
    cruzthepug is offline Member
    Join Date
    Mar 2008
    Location
    Alabama
    Posts
    347
    Are you using the stock Kimber mag or another brand?

  6. #5
    Dsig1's Avatar
    Dsig1 is offline Member
    Join Date
    Dec 2007
    Location
    Lancaster, PA
    Posts
    687
    As described, you should be seeing the misfeed in nearly slow motion in two Kimbers. I don't see this as a viable possibility, being the same failure in both guns, in the same manner. Did this happen after a cleaning session for both guns where you could have reassembled them incorrectly in the same manner? If not, all I can think of is are you are not fully setting the magazine into the housing opening.

    With the slide open and no magazine in, I'd try inserting one of the bullets in question into the barrel to check for fit. It should chamber easily by hand. That would eliminate the ammo as a problem.

    Next try a mag with only one bullet and see if it loads correctly with the slide started in the back position, held by the slide stop.

    Next, try with one less bullet than the max in the mag.

    This should let you know more about the mag and mag spring.

    Sounds more like a mag spring or mag catch problem but again, if happening in both guns the same way I'd look for operators error.

  7. #6
    rbwomble is offline Junior Member
    Join Date
    Dec 2008
    Location
    Wichita Falls, Tx
    Posts
    18
    Quote Originally Posted by Dsig1 View Post
    As described, you should be seeing the misfeed in nearly slow motion in two Kimbers. I don't see this as a viable possibility, being the same failure in both guns, in the same manner. Did this happen after a cleaning session for both guns where you could have reassembled them incorrectly in the same manner? If not, all I can think of is are you are not fully setting the magazine into the housing opening.

    With the slide open and no magazine in, I'd try inserting one of the bullets in question into the barrel to check for fit. It should chamber easily by hand. That would eliminate the ammo as a problem.

    Next try a mag with only one bullet and see if it loads correctly with the slide started in the back position, held by the slide stop.

    Next, try with one less bullet than the max in the mag.

    This should let you know more about the mag and mag spring.

    Sounds more like a mag spring or mag catch problem but again, if happening in both guns the same way I'd look for operators error.
    Thanks! Weather permitting I'll try some more at the range.

  8. #7
    DevilsJohnson is offline Senior Member
    Join Date
    Oct 2007
    Location
    Kentucky
    Posts
    3,373
    Sounds like a really tight mag spring. Some of those Kimbers have pretty tight chambers too so you add the mag spring in with that you will see that problem a lot.

  9. #8
    rbwomble is offline Junior Member
    Join Date
    Dec 2008
    Location
    Wichita Falls, Tx
    Posts
    18
    Quote Originally Posted by DevilsJohnson View Post
    Sounds like a really tight mag spring. Some of those Kimbers have pretty tight chambers too so you add the mag spring in with that you will see that problem a lot.
    I have Wilson mags. It happens when I feed it UMCs or Magtechs. It shoots perfect with Hornady hollow points! I guess I need to find a different practice amo. It never jams after it chambered.......are bullets that different in size or shape? These are all 230 gr.

  10. #9
    alkersrd is offline Junior Member
    Join Date
    Nov 2008
    Location
    Alpharetta,Ga
    Posts
    3

    Kimber Mags :

    Had simular problems with my SIS during break-in period the first 300-500 rds it would not feed blazer brass, switched to Tripp Mags and it will now feed any ammo

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

handgun feed problems
,

kimber chamber

,

kimber feed problems

,

kimber feeding problems

,
kimber not feeding
,

kimber problems feeding

,
kimber problems with cheaper ammo
,
kimber rimfire problems
,
kimber rimfire target feed problems
,
kimber slide not going forward all the way
,
kimber slide stop problem
,

kimber tight chamber

Click on a term to search for related topics.