Results 1 to 5 of 5
  1. #1
    8Eric6's Avatar
    8Eric6 is offline Member
    Join Date
    May 2010
    Location
    Illinois
    Posts
    205

    new pf9 owner with a problem

    the other day I bought a new Pf9 brought it home polished the feed ramp and barrel and cleaned it yada yada today I took it to the range and had an unfired round get stuck in the barrel upon racking the slide this happened once at the range and twice at home with a snap cap is this just the round not being seated all the way back in the mag or something?? thanks

  2. #2
    Join Date
    Jan 2008
    Location
    NC
    Posts
    244
    Check the bolt that holds extractor for tightness?

  3. #3
    MitchellB's Avatar
    MitchellB is offline Member
    Join Date
    Aug 2010
    Location
    Greensboro
    Posts
    147
    The barrel chamber on my PF9 also got an empty brass case stuck. The chamber on my PF9 was slightly tighter than the chamber on my S&W that the fired case came from. So, I lightly polished of the chamber of my PF9 before it was ever fired and it has been flawless so far. Also check the claw on the end of the extractor. I have heard of them chipping causing FTE. The Keltec PF9 forum may be of some help also.

  4. #4
    jflecken is offline Junior Member
    Join Date
    May 2011
    Location
    Asheboro NC
    Posts
    23
    I had the same problem with my PF9. This did not happen occasionally it happened every mag, at least once. Check thread Problem with PF-9. I ended up sending mine back to KT. Twice. The second time they replaced barrel, extractor and screw, ejector, mag release and mag plunger. Also they polished the ramp and chamber. Since I got it back it has not had a FTE. I believe my chamber was out of round. I checked the casings that would stick and they were out of round, some .006". Do not know if this is your problem but it sounds similar. Also have heard others complaining of the same thing. This may be a problem that KT had with a certain run of barrels, may not. Do not know what to say but that is what happened to me and how it was fixed. Best of luck. When I sent mine back I also sent some of the spent casings back with the gun so they could see for them selves.

  5. #5
    8Eric6's Avatar
    8Eric6 is offline Member
    Join Date
    May 2010
    Location
    Illinois
    Posts
    205
    thanks to everybody who posted!!! My problem isn't it ejecting the casing after being fired. It's right when I load the first round sometimes the UNFIRED round slides forward and sits flush in the barrel and wont go all the way back in battery I have to release the mag and shake it out sometimes I have to field strip it and pull the round out of the barrel by hand. It fires fine and thus far I haven't had any problems during firing only the first round out of the mag when I first chamber it. After I pull the round out I can put it back in the mag and it will fire fine. It's just once in a blue moon out of 220 rounds it happened once and couple of times with a snap cap

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

kel tec pf9 barrel lug
,
kel tec pf9 ejector problems
,
kel tec pf9 problems
,

kel tec pf9 slide stuck

,
kel tec pf9 threaded barrel
,
keltec pf9 problems
,

pf9 barrel

,

pf9 problems

,

pf9 slide stuck

,
pf9 threaded barrel
,
polishing keltec pf9 feed ramp
,
slide sticks going forward on pf9
Click on a term to search for related topics.

» Springfield Armory

» HGF Sponsors

Powered by vBadvanced CMPS v4.2.1