Slide malfunction?
Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By fauxpa46

Thread: Slide malfunction?

  1. #1
    Junior Member
    Join Date
    Mar 2016
    Location
    Pennsylvania
    Posts
    48

    Slide malfunction?

    Why would a slide not now lock open after firing last shot when it used to do so?

  2. #2
    Administrator
    VAMarine's Avatar
    Join Date
    Dec 2008
    Location
    Iowa
    Posts
    3,920
    Most times its the shooter getting their hands in the way and riding the slide stop.

    Could be a defective magazine, could be a defective gun...

    What kind if gun?

    Sent from my SM-G920R4 using Tapatalk









  3. #3
    Junior Member
    Join Date
    Mar 2016
    Location
    Pennsylvania
    Posts
    48
    PPS (M1) I don't think any digits are in the way. That's a pretty powerful kick-back afterall. Also, doesn't appear to be any one mag; I use four.

    Sent from my SAMSUNG-SM-N910A using Tapatalk

  4. Remove Advertisements
    HandgunForum.net
    Advertisements
     

  5. #4
    Administrator
    VAMarine's Avatar
    Join Date
    Dec 2008
    Location
    Iowa
    Posts
    3,920
    Quote Originally Posted by fauxpa46 View Post
    PPS (M1) I don't think any digits are in the way. That's a pretty powerful kick-back afterall. Also, doesn't appear to be any one mag; I use four.

    Sent from my SAMSUNG-SM-N910A using Tapatalk
    Assuming you are rifht handed, it's probbaly shooter induced. Fire it one handed or two handed with yor thumb curled down.



    Vs a thumbs forward grip



    Pics courtesy of Lucky Gunner
    http://www.luckygunner.com/lounge/whats-wrong-grip/

    Sent from my SM-G920R4 using Tapatalk









  6. #5
    Junior Member
    Join Date
    Mar 2016
    Location
    Pennsylvania
    Posts
    48
    Okay. Certainly worth a try. Thanks.

    Sent from my SAMSUNG-SM-N910A using Tapatalk
    VAMarine likes this.

  7. #6
    Administrator
    VAMarine's Avatar
    Join Date
    Dec 2008
    Location
    Iowa
    Posts
    3,920
    Quote Originally Posted by fauxpa46 View Post
    Okay. Certainly worth a try. Thanks.

    Sent from my SAMSUNG-SM-N910A using Tapatalk
    You're welcome, let us know how it goes.

    Sent from my SM-G920R4 using Tapatalk









  8. #7
    Member
    Join Date
    Mar 2016
    Location
    NE PA
    Posts
    199
    Did you check inside the frame make sure the tab that pushes up the slide lock is working.

  9. #8
    Junior Member
    Join Date
    Mar 2016
    Location
    Pennsylvania
    Posts
    48
    With an empty mag (and nothing in battery of course), when I pull back on the slide it locks itself, so I don't think there is anything amiss internally. I guess I'll have to shoot it again, watching the placement of my hands as suggested. As to the mags and their springs, they are all no more than four and a half months old, with only perhaps 250-300 rounds fired through the pistol.

  10. #9
    Member OldManMontgomery's Avatar
    Join Date
    Nov 2013
    Location
    Hastings, Nebraska; the Heartland!
    Posts
    144
    The only time I've problems like this is a Government Model and one or two specific magazines. The joggy bit that activates the slide stop from the inside doesn't seem to properly connect. You relate you have tried the function with an empty gun. My 'bad' magazines worked fairly well when going through the motions; when the pistol fired, the jolt seemed to hinder it.

    I've had problems with a Glock with my fingers getting in the way, but it seems to be the reverse. It put the slide lock "up" rather than preventing it from moving up. Try shooting the pistol one handed with the support hand (and fingers) completely out of the picture; see if that does anything different.

    The inner surface of the slide lock could be worn, but that would take a fair amount of erosion, I would think.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •